fix: HAVE_SCHED_SETAFFINITY is not defined
[urcu.git] / src / Makefile.am
index 88ccc1f977ec6a2f42538389c3bd45897742291a..37fa9fe94d562a71cdc2aee09ae31572a2153106 100644 (file)
@@ -1,22 +1,13 @@
-AM_CPPFLAGS += -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_srcdir)/src
+AM_CPPFLAGS += -I$(top_srcdir)/src
 
 #Add the -version-info directly here since we are only building
 # library that use the version-info
-AM_LDFLAGS=-version-info $(URCU_LIBRARY_VERSION)
-if USE_CYGWIN
-AM_LDFLAGS+=-no-undefined
-endif
+AM_LDFLAGS=-version-info $(URCU_LIBRARY_VERSION) $(LT_NO_UNDEFINED)
 
 dist_noinst_HEADERS = urcu-die.h urcu-wait.h compat-getcpu.h \
        compat-rand.h urcu-utils.h
 
-if COMPAT_ARCH
-COMPAT=compat_arch_@ARCHTYPE@.c
-else
-COMPAT=
-endif
-
-COMPAT+=compat_futex.c
+COMPAT = compat_arch.c compat_futex.c
 
 RCULFHASH = rculfhash.c rculfhash-mm-order.c rculfhash-mm-chunk.c \
                rculfhash-mm-mmap.c
@@ -63,7 +54,7 @@ pkgconfigdir = $(libdir)/pkgconfig
 pkgconfig_DATA = liburcu-cds.pc liburcu.pc liburcu-bp.pc liburcu-qsbr.pc \
        liburcu-signal.pc liburcu-mb.pc
 
-EXTRA_DIST = compat_arch_x86.c \
+EXTRA_DIST = \
        urcu-call-rcu-impl.h \
        urcu-defer-impl.h \
        rculfhash-internal.h
This page took 0.02318 seconds and 4 git commands to generate.