fix: handle EINTR correctly in get_cpu_mask_from_sysfs
[urcu.git] / doc / examples / Makefile.am
index 6828eee1e9c2b96c38676fd49c9e7f8720633abc..81691692ed5a77aac6132058bd72f7347642ad55 100644 (file)
@@ -1,3 +1,7 @@
+# SPDX-FileCopyrightText: 2023 EfficiOS Inc.
+#
+# SPDX-License-Identifier: MIT
+
 doc_examplesdir = ${docdir}/examples
 
 doc_examples_urcu_flavorsdir = ${doc_examplesdir}/urcu-flavors
@@ -7,12 +11,10 @@ dist_doc_examples_urcu_flavors_DATA = \
        urcu-flavors/Makefile.qsbr \
        urcu-flavors/Makefile.mb \
        urcu-flavors/Makefile.membarrier \
-       urcu-flavors/Makefile.signal \
        urcu-flavors/Makefile.bp \
        urcu-flavors/qsbr.c \
        urcu-flavors/mb.c \
        urcu-flavors/membarrier.c \
-       urcu-flavors/signal.c \
        urcu-flavors/bp.c
 
 dist_doc_examples_DATA = \
@@ -111,17 +113,15 @@ dist_doc_examples_rculfhash_DATA = \
        rculfhash/cds_lfht_lookup.c \
        rculfhash/cds_lfht_for_each_entry_duplicate.c
 
-if NO_SHARED
-# Don't build examples if shared libraries support was explicitly
-# disabled.
-else
+# Building the examples requires the shared libraries to be enabled
+if ENABLE_EXAMPLES
 
 SUBDIRS_PROXY = hlist list urcu-flavors wfcqueue rculfqueue \
        wfstack lfstack rculfhash
 
 # Copies are for VPATH build support.
 all-local:
-       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+       $(AM_V_at)if [ x"$(srcdir)" != x"$(builddir)" ]; then \
                cp -pfR $(srcdir)/dist-files $(builddir); \
                chmod -R u+w $(builddir)/dist-files; \
                cp -pf $(srcdir)/Makefile.examples.template $(builddir); \
@@ -132,23 +132,19 @@ all-local:
                done; \
        fi; \
        if [ x"$(shell echo "$(top_srcdir)" | $(GREP) "^/" | wc -l)" = x"1" ]; then \
-               echo "Examples: absolute top_srcdir path $(top_srcdir)"; \
                rel_src_subdir=""; \
        else \
-               echo "Examples: relative top_srcdir path $(top_srcdir)"; \
                rel_src_subdir="../"; \
        fi; \
        if [ x"$(shell echo "$(top_builddir)" | $(GREP) "^/" | wc -l)" = x"1" ]; then \
-               echo "Examples: absolute top_builddir path $(top_builddir)"; \
                rel_build_subdir=""; \
        else \
-               echo "Examples: relative top_builddir path $(top_builddir)"; \
                rel_build_subdir="../"; \
        fi; \
-       $(MAKE) -f dist-files/Makefile AM_CC="$(CC)" AM_CPPFLAGS="$(CPPFLAGS) -I$$rel_src_subdir/$(top_srcdir)/ -I$$rel_build_subdir$(top_builddir)/" AM_CFLAGS='$(CFLAGS)' AM_LDFLAGS='$(LDFLAGS) -L../../../.libs/ -Wl,-rpath "$(PWD)/../../.libs/"' $(AM_MAKEFLAGS) all;
+       $(MAKE) -f dist-files/Makefile CC="$(CC)" CPPFLAGS="$(CPPFLAGS)" AM_CPPFLAGS="$(AM_CPPFLAGS) -I"$${rel_src_subdir}/$(top_srcdir)/include/" -I"$${rel_src_subdir}/$(top_srcdir)/src/" -I"$${rel_build_subdir}$(top_builddir)/include/" -I"$${rel_build_subdir}$(top_builddir)/include/src/"" CFLAGS="$(CFLAGS)" AM_CFLAGS="$(AM_CFLAGS)" LDFLAGS="$(LDFLAGS)" AM_LDFLAGS="$(AM_LDFLAGS) -L../../../src/.libs/ -Wl,-rpath "$(PWD)/../../src/.libs/"" AM_V_P="$(AM_V_P)" AM_V_at="$(AM_V_at)" $(AM_MAKEFLAGS) all;
 
 clean-local:
-       @$(MAKE) -f dist-files/Makefile $(AM_MAKEFLAGS) clean; \
+       $(AM_V_at)$(MAKE) -f dist-files/Makefile $(AM_MAKEFLAGS) clean; \
        if [ x"$(srcdir)" != x"$(builddir)" ]; then \
                for subdir in $(SUBDIRS_PROXY); do \
                        rm -rf $(builddir)/$$subdir; \
This page took 0.023509 seconds and 4 git commands to generate.