Cleanup: remove leftover manual pthread detection
[urcu.git] / tests / benchmark / Makefile.am
index 7be25256e0a07ef601138c252197b2115a9447ce..f513ed4c00f958ccc7074293951753f3a981ec5c 100644 (file)
@@ -1,6 +1,3 @@
-if !LIBC_INCLUDES_PTHREAD
-AM_LDFLAGS=-lpthread
-endif
 AM_CFLAGS=-I$(top_srcdir) -I$(top_builddir) -I$(top_srcdir)/tests/common -g
 
 SCRIPT_LIST = common.sh \
@@ -20,7 +17,11 @@ SCRIPT_LIST = common.sh \
 
 dist_noinst_SCRIPTS = $(SCRIPT_LIST)
 
-dist_noinst_DATA = regression_tests short_bench_tests long_bench_tests
+TEST_LIST = regression_tests \
+       short_bench_tests \
+       long_bench_tests
+
+dist_noinst_DATA = $(TEST_LIST)
 
 noinst_PROGRAMS = test_urcu test_urcu_dynamic_link test_urcu_timing \
        test_urcu_signal test_urcu_signal_dynamic_link test_urcu_signal_timing \
@@ -213,14 +214,14 @@ test_urcu_hash_LDADD = $(URCU_QSBR_LIB) $(URCU_COMMON_LIB) $(URCU_CDS_LIB)
 
 all-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
-               for script in $(SCRIPT_LIST); do \
+               for script in $(SCRIPT_LIST) $(TEST_LIST); do \
                        cp -f $(srcdir)/$$script $(builddir); \
                done; \
        fi
 
 clean-local:
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
-               for script in $(SCRIPT_LIST); do \
+               for script in $(SCRIPT_LIST) $(TEST_LIST); do \
                        rm -f $(builddir)/$$script; \
                done; \
        fi
This page took 0.023435 seconds and 4 git commands to generate.