Python bindings: warnings in generated code causes build failure
[lttng-tools.git] / extras / bindings / swig / python / Makefile.am
index a8fd56d806ed300fc71aff206b51827c3b92d8f7..29914e5cd5404e131393e310efaf8efe9ed53d97 100644 (file)
@@ -7,12 +7,17 @@ lttng.i: lttng.i.in
 # `swig_this` shadows a global of the same name.  Later versions (like 4.0.1)
 # have renamed this global to `Swig_This_global`.
 #
-# Disable -Wshadow for that file.
-AM_CFLAGS += -Wno-shadow
-
-AM_CFLAGS += -Wno-missing-field-initializers
-
-AM_CFLAGS += -Wno-cast-function-type
+# Disable some warning flags for that file.
+AM_CFLAGS += \
+       -Wno-cast-function-type \
+       -Wno-missing-field-initializers \
+       -Wno-redundant-decls \
+       -Wno-shadow \
+       -Wno-unused-parameter
+
+# Swig regularily changes and generates code that results warnings which break
+# Werror builds. Disable that option for this sub-project.
+AM_CFLAGS += -Wno-error
 
 AM_CPPFLAGS += $(PYTHON_INCLUDE)
 
This page took 0.02499 seconds and 4 git commands to generate.