Update README for ARM support
authorMathieu Desnoyers <mathieu.desnoyers@efficios.com>
Fri, 18 Jun 2010 16:47:24 +0000 (12:47 -0400)
committerMathieu Desnoyers <mathieu.desnoyers@efficios.com>
Fri, 18 Jun 2010 16:47:24 +0000 (12:47 -0400)
Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
README

diff --git a/README b/README
index 4423fc53821c0c62244481cd8e94d8e4c837fc4f..796b9cfcd4dbad1d87775b22e53559dcdf7df7ed 100644 (file)
--- a/README
+++ b/README
@@ -25,11 +25,10 @@ ARCHITECTURES SUPPORTED
 -----------------------
 
 Currently, x86 (i386, i486, i586, i686), x86 64-bit, PowerPC 32/64, S390, S390x
-and Sparcv9 32/64 are supported. Only tested on Linux so far, but should
-theoretically work on other operating systems.
+ARMv7l, Alpha, ia64 and Sparcv9 32/64 are supported. Only tested on Linux so
+far, but should theoretically work on other operating systems.
 
-Alpha and ia64 architectures are supported, but depend on 4.x gcc with atomic
-builtins support.
+ARMv7l depends on running a Linux kernel 2.6.15 or better.
 
 The gcc compiler versions 3.3, 3.4, 4.0, 4.1, 4.2, 4.3, 4.4 and 4.5 are
 supported, with the following exceptions:
@@ -39,6 +38,9 @@ supported, with the following exceptions:
   therefore not compatible with liburcu on x86 32-bit (i386, i486, i586, i686).
   The problem has been reported to the gcc community:
     http://www.mail-archive.com/gcc-bugs@gcc.gnu.org/msg281255.html
+- Alpha, ia64 and ARMv7l architectures depend on 4.x gcc with atomic builtins
+  support.
+
 
 QUICK START GUIDE
 -----------------
This page took 0.033654 seconds and 4 git commands to generate.