uatomic/x86: Remove redundant memory barriers
[urcu.git] / tests / utils / Makefile.am
index 6f45810ba303707db6f02cb7d1fd7443d852ecb0..605d64c953deb5540b3971ad47cd6f828379e608 100644 (file)
@@ -1,20 +1,13 @@
-noinst_LIBRARIES = libtap.a
-libtap_a_SOURCES = tap.c tap.h
-
-SCRIPT_LIST = tap.sh
+# SPDX-FileCopyrightText: 2023 EfficiOS Inc.
+#
+# SPDX-License-Identifier: MIT
 
 
-dist_noinst_SCRIPTS = $(SCRIPT_LIST)
+AM_CPPFLAGS += -I$(top_srcdir)/src
 
 
-all-local:
-       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
-               for script in $(SCRIPT_LIST); do \
-                       cp -f $(srcdir)/$$script $(builddir); \
-               done; \
-       fi
+noinst_LIBRARIES = libtap.a
+libtap_a_SOURCES = tap.c tap.h
 
 
-clean-local:
-       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
-               for script in $(SCRIPT_LIST); do \
-                       rm -f $(builddir)/$$script; \
-               done; \
-       fi
+dist_check_SCRIPTS = \
+       tap-driver.sh \
+       tap.sh \
+       utils.sh
This page took 0.023013 seconds and 4 git commands to generate.