Fix: typo CPPLAGS in examples Makefile
[urcu.git] / doc / examples / Makefile.am
index bf1901691e7b5d034a2cba529a3bf8cdbe12251f..edf00ebe3e6222a523c30baf287e13ab093e6dc4 100644 (file)
@@ -100,18 +100,56 @@ dist_doc_examples_rculfhash_DATA = \
        rculfhash/Makefile.cds_lfht_add_unique \
        rculfhash/Makefile.cds_lfht_add_replace \
        rculfhash/Makefile.cds_lfht_del \
+       rculfhash/Makefile.cds_lfht_destroy \
+       rculfhash/Makefile.cds_lfht_lookup \
+       rculfhash/Makefile.cds_lfht_for_each_entry_duplicate \
        rculfhash/cds_lfht_add.c \
        rculfhash/cds_lfht_add_unique.c \
        rculfhash/cds_lfht_add_replace.c \
-       rculfhash/cds_lfht_del.c
+       rculfhash/cds_lfht_del.c \
+       rculfhash/cds_lfht_destroy.c \
+       rculfhash/cds_lfht_lookup.c \
+       rculfhash/cds_lfht_for_each_entry_duplicate.c
 
 if NO_SHARED
 # Don't build examples if shared libraries support was explicitly
 # disabled.
 else
+
+SUBDIRS_PROXY = hlist list urcu-flavors wfcqueue rculfqueue \
+       wfstack lfstack rculfhash
+
+# Copies are for VPATH build support.
 all-local:
-       $(MAKE) -f dist-files/Makefile AM_CPPFLAGS="-I../../../urcu/ -I../../../" AM_LDFLAGS='-L../../../.libs/ -Wl,-rpath="$(PWD)/../../.libs/"' $(AM_MAKEFLAGS) all
+       $(AM_V_at)if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               cp -pfR $(srcdir)/dist-files $(builddir); \
+               chmod -R u+w $(builddir)/dist-files; \
+               cp -pf $(srcdir)/Makefile.examples.template $(builddir); \
+               chmod u+w $(builddir)/Makefile.examples.template; \
+               for subdir in $(SUBDIRS_PROXY); do \
+                       cp -pfR $(srcdir)/$$subdir $(builddir); \
+                       chmod -R u+w $(builddir)/$$subdir; \
+               done; \
+       fi; \
+       if [ x"$(shell echo "$(top_srcdir)" | $(GREP) "^/" | wc -l)" = x"1" ]; then \
+               rel_src_subdir=""; \
+       else \
+               rel_src_subdir="../"; \
+       fi; \
+       if [ x"$(shell echo "$(top_builddir)" | $(GREP) "^/" | wc -l)" = x"1" ]; then \
+               rel_build_subdir=""; \
+       else \
+               rel_build_subdir="../"; \
+       fi; \
+       $(MAKE) -f dist-files/Makefile CC="$(CC)" CPPFLAGS="$(CPPFLAGS)" AM_CPPFLAGS="$(AM_CPPFLAGS) -I"$${rel_src_subdir}/$(top_srcdir)/include/" -I"$${rel_src_subdir}/$(top_srcdir)/src/" -I"$${rel_build_subdir}$(top_builddir)/include/" -I"$${rel_build_subdir}$(top_builddir)/include/src/"" CFLAGS="$(CFLAGS)" AM_CFLAGS="$(AM_CFLAGS)" LDFLAGS="$(LDFLAGS)" AM_LDFLAGS="$(AM_LDFLAGS) -L../../../src/.libs/ -Wl,-rpath "$(PWD)/../../src/.libs/"" AM_V_P="$(AM_V_P)" AM_V_at="$(AM_V_at)" $(AM_MAKEFLAGS) all;
 
 clean-local:
-       $(MAKE) -f dist-files/Makefile $(AM_MAKEFLAGS) clean;
+       $(AM_V_at)$(MAKE) -f dist-files/Makefile $(AM_MAKEFLAGS) clean; \
+       if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for subdir in $(SUBDIRS_PROXY); do \
+                       rm -rf $(builddir)/$$subdir; \
+               done; \
+               rm -f $(builddir)/Makefile.examples.template; \
+               rm -rf $(builddir)/dist-files; \
+       fi;
 endif
This page took 0.023422 seconds and 4 git commands to generate.