Fix: typo CPPLAGS in examples Makefile
[urcu.git] / doc / examples / Makefile.am
index 313f5215b254f908eeab9502f455ef67ef3a41b6..edf00ebe3e6222a523c30baf287e13ab093e6dc4 100644 (file)
@@ -121,31 +121,30 @@ SUBDIRS_PROXY = hlist list urcu-flavors wfcqueue rculfqueue \
 
 # Copies are for VPATH build support.
 all-local:
-       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+       $(AM_V_at)if [ x"$(srcdir)" != x"$(builddir)" ]; then \
                cp -pfR $(srcdir)/dist-files $(builddir); \
+               chmod -R u+w $(builddir)/dist-files; \
                cp -pf $(srcdir)/Makefile.examples.template $(builddir); \
+               chmod u+w $(builddir)/Makefile.examples.template; \
                for subdir in $(SUBDIRS_PROXY); do \
                        cp -pfR $(srcdir)/$$subdir $(builddir); \
+                       chmod -R u+w $(builddir)/$$subdir; \
                done; \
        fi; \
        if [ x"$(shell echo "$(top_srcdir)" | $(GREP) "^/" | wc -l)" = x"1" ]; then \
-               echo "Examples: absolute top_srcdir path $(top_srcdir)"; \
                rel_src_subdir=""; \
        else \
-               echo "Examples: relative top_srcdir path $(top_srcdir)"; \
                rel_src_subdir="../"; \
        fi; \
        if [ x"$(shell echo "$(top_builddir)" | $(GREP) "^/" | wc -l)" = x"1" ]; then \
-               echo "Examples: absolute top_builddir path $(top_builddir)"; \
                rel_build_subdir=""; \
        else \
-               echo "Examples: relative top_builddir path $(top_builddir)"; \
                rel_build_subdir="../"; \
        fi; \
-       $(MAKE) -f dist-files/Makefile AM_CC="$(CC)" AM_CPPFLAGS="$(CPPFLAGS) -I$$rel_src_subdir/$(top_srcdir)/ -I$$rel_build_subdir$(top_builddir)/" AM_CFLAGS='$(CFLAGS)' AM_LDFLAGS='$(LDFLAGS) -L../../../.libs/ -Wl,-rpath "$(PWD)/../../.libs/"' $(AM_MAKEFLAGS) all;
+       $(MAKE) -f dist-files/Makefile CC="$(CC)" CPPFLAGS="$(CPPFLAGS)" AM_CPPFLAGS="$(AM_CPPFLAGS) -I"$${rel_src_subdir}/$(top_srcdir)/include/" -I"$${rel_src_subdir}/$(top_srcdir)/src/" -I"$${rel_build_subdir}$(top_builddir)/include/" -I"$${rel_build_subdir}$(top_builddir)/include/src/"" CFLAGS="$(CFLAGS)" AM_CFLAGS="$(AM_CFLAGS)" LDFLAGS="$(LDFLAGS)" AM_LDFLAGS="$(AM_LDFLAGS) -L../../../src/.libs/ -Wl,-rpath "$(PWD)/../../src/.libs/"" AM_V_P="$(AM_V_P)" AM_V_at="$(AM_V_at)" $(AM_MAKEFLAGS) all;
 
 clean-local:
-       @$(MAKE) -f dist-files/Makefile $(AM_MAKEFLAGS) clean; \
+       $(AM_V_at)$(MAKE) -f dist-files/Makefile $(AM_MAKEFLAGS) clean; \
        if [ x"$(srcdir)" != x"$(builddir)" ]; then \
                for subdir in $(SUBDIRS_PROXY); do \
                        rm -rf $(builddir)/$$subdir; \
This page took 0.02289 seconds and 4 git commands to generate.