doc/examples: add membarrier flavor
[urcu.git] / doc / examples / Makefile.am
index d516bb6b1a51b5c74bdd49f52698df5e2779911c..e6d68702370b8e09cbeae573d6336111560df9e1 100644 (file)
@@ -1,10 +1,17 @@
 doc_examplesdir = ${docdir}/examples
 
-doc_examples_qsbr_minimaldir = ${doc_examplesdir}/qsbr-minimal
-
-dist_doc_examples_qsbr_minimal_DATA = \
-       qsbr-minimal/Makefile \
-       qsbr-minimal/qsbr-minimal.c
+doc_examples_urcu_flavorsdir = ${doc_examplesdir}/urcu-flavors
+
+dist_doc_examples_urcu_flavors_DATA = \
+       urcu-flavors/Makefile \
+       urcu-flavors/Makefile.qsbr \
+       urcu-flavors/Makefile.mb \
+       urcu-flavors/Makefile.membarrier \
+       urcu-flavors/Makefile.signal \
+       urcu-flavors/qsbr.c \
+       urcu-flavors/mb.c \
+       urcu-flavors/membarrier.c \
+       urcu-flavors/signal.c
 
 dist_doc_examples_DATA = \
        Makefile.examples.template
@@ -76,15 +83,15 @@ if NO_SHARED
 # Don't build examples if shared libraries support was explicitly
 # disabled.
 else
-SUBDIRS_PROXY = qsbr-minimal list hlist wfcqueue wfstack lfstack
+SUBDIRS_PROXY = urcu-flavors list hlist wfcqueue wfstack lfstack
 
 all-local:
        for subdir in $(SUBDIRS_PROXY); do \
-               cd $$subdir && $(MAKE) AM_CPPFLAGS="-I../../../urcu/ -I../../../" AM_LDFLAGS='-L../../../.libs/ -Wl,-rpath="$(PWD)/../../.libs/"' $(AM_MAKEFLAGS) all; cd ..; \
+               cd $$subdir && $(MAKE) AM_CPPFLAGS="-I../../../urcu/ -I../../../" AM_LDFLAGS='-L../../../.libs/ -Wl,-rpath="$(PWD)/../../.libs/"' $(AM_MAKEFLAGS) all && cd ..; \
        done
 
 clean-local:
        for subdir in $(SUBDIRS_PROXY); do \
-               cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) clean; cd ..; \
+               cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) clean && cd ..; \
        done
 endif
This page took 0.023159 seconds and 4 git commands to generate.