doc/examples: lfstack
[urcu.git] / doc / examples / Makefile.am
index d964c06733445826a7ad484b1b1573375e5f362c..9471957f879ae613e7853b9d3f54c87b3d2091d9 100644 (file)
@@ -29,6 +29,7 @@ dist_doc_examples_list_DATA = \
 doc_examples_wfcqueuedir = ${doc_examplesdir}/wfcqueue
 
 dist_doc_examples_wfcqueue_DATA = \
+       wfcqueue/Makefile \
        wfcqueue/Makefile.cds_wfcq_enqueue \
        wfcqueue/Makefile.cds_wfcq_dequeue \
        wfcqueue/Makefile.cds_wfcq_splice \
@@ -36,11 +37,33 @@ dist_doc_examples_wfcqueue_DATA = \
        wfcqueue/cds_wfcq_dequeue.c \
        wfcqueue/cds_wfcq_splice.c
 
+doc_examples_wfstackdir = ${doc_examplesdir}/wfstack
+
+dist_doc_examples_wfstack_DATA = \
+       wfstack/Makefile \
+       wfstack/Makefile.cds_wfs_push \
+       wfstack/Makefile.cds_wfs_pop \
+       wfstack/Makefile.cds_wfs_pop_all_blocking \
+       wfstack/cds_wfs_push.c \
+       wfstack/cds_wfs_pop.c \
+       wfstack/cds_wfs_pop_all_blocking.c
+
+doc_examples_lfstackdir = ${doc_examplesdir}/lfstack
+
+dist_doc_examples_lfstack_DATA = \
+       lfstack/Makefile \
+       lfstack/Makefile.cds_lfs_push \
+       lfstack/Makefile.cds_lfs_pop_blocking \
+       lfstack/Makefile.cds_lfs_pop_all_blocking \
+       lfstack/cds_lfs_push.c \
+       lfstack/cds_lfs_pop_blocking.c \
+       lfstack/cds_lfs_pop_all_blocking.c
+
 if NO_SHARED
 # Don't build examples if shared libraries support was explicitly
 # disabled.
 else
-SUBDIRS_PROXY = qsbr-minimal list wfcqueue
+SUBDIRS_PROXY = qsbr-minimal list wfcqueue wfstack
 
 all-local:
        for subdir in $(SUBDIRS_PROXY); do \
This page took 0.022668 seconds and 4 git commands to generate.