doc/examples: cds_lfht_destroy
[urcu.git] / doc / examples / Makefile.am
index 0f3129b94d9d94f84859586ea24f0080b4006c23..31bac6d9544ced6ed4244dc8ce4658cb42e1bc1f 100644 (file)
@@ -6,12 +6,17 @@ dist_doc_examples_urcu_flavors_DATA = \
        urcu-flavors/Makefile \
        urcu-flavors/Makefile.qsbr \
        urcu-flavors/Makefile.mb \
+       urcu-flavors/Makefile.membarrier \
        urcu-flavors/Makefile.signal \
+       urcu-flavors/Makefile.bp \
        urcu-flavors/qsbr.c \
        urcu-flavors/mb.c \
-       urcu-flavors/signal.c
+       urcu-flavors/membarrier.c \
+       urcu-flavors/signal.c \
+       urcu-flavors/bp.c
 
 dist_doc_examples_DATA = \
+       dist-files/Makefile \
        Makefile.examples.template
 
 doc_examples_listdir = ${doc_examplesdir}/list
@@ -77,19 +82,38 @@ dist_doc_examples_lfstack_DATA = \
        lfstack/cds_lfs_pop_blocking.c \
        lfstack/cds_lfs_pop_all_blocking.c
 
+doc_examples_rculfqueuedir = ${doc_examplesdir}/rculfqueue
+
+dist_doc_examples_rculfqueue_DATA = \
+       rculfqueue/Makefile \
+       rculfqueue/Makefile.cds_lfq_enqueue \
+       rculfqueue/Makefile.cds_lfq_dequeue \
+       rculfqueue/cds_lfq_enqueue.c \
+       rculfqueue/cds_lfq_dequeue.c
+
+doc_examples_rculfhashdir = ${doc_examplesdir}/rculfhash
+
+dist_doc_examples_rculfhash_DATA = \
+       rculfhash/Makefile \
+       rculfhash/jhash.h \
+       rculfhash/Makefile.cds_lfht_add \
+       rculfhash/Makefile.cds_lfht_add_unique \
+       rculfhash/Makefile.cds_lfht_add_replace \
+       rculfhash/Makefile.cds_lfht_del \
+       rculfhash/Makefile.cds_lfht_destroy \
+       rculfhash/cds_lfht_add.c \
+       rculfhash/cds_lfht_add_unique.c \
+       rculfhash/cds_lfht_add_replace.c \
+       rculfhash/cds_lfht_del.c \
+       rculfhash/cds_lfht_destroy.c
+
 if NO_SHARED
 # Don't build examples if shared libraries support was explicitly
 # disabled.
 else
-SUBDIRS_PROXY = urcu-flavors list hlist wfcqueue wfstack lfstack
-
 all-local:
-       for subdir in $(SUBDIRS_PROXY); do \
-               cd $$subdir && $(MAKE) AM_CPPFLAGS="-I../../../urcu/ -I../../../" AM_LDFLAGS='-L../../../.libs/ -Wl,-rpath="$(PWD)/../../.libs/"' $(AM_MAKEFLAGS) all && cd ..; \
-       done
+       $(MAKE) -f dist-files/Makefile AM_CPPFLAGS="-I../../../urcu/ -I../../../" AM_LDFLAGS='-L../../../.libs/ -Wl,-rpath="$(PWD)/../../.libs/"' $(AM_MAKEFLAGS) all
 
 clean-local:
-       for subdir in $(SUBDIRS_PROXY); do \
-               cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) clean && cd ..; \
-       done
+       $(MAKE) -f dist-files/Makefile $(AM_MAKEFLAGS) clean;
 endif
This page took 0.024153 seconds and 4 git commands to generate.