Add a test script to do profiling. Some cleaning as well.
[lttv.git] / ltt / branches / poly / configure.in
index cd36993b173e7c432bfe3bcf7ed27d42072ae93d..bdbc2e8affa130fa42349f230a263f13a9c51d9c 100644 (file)
@@ -1,26 +1,56 @@
+# This file is part of the Linux Trace Toolkit viewer
+# Copyright (C) 2003-2004 Mathieu Desnoyers
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License Version 2 as
+# published by the Free Software Foundation;
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, 
+# MA 02111-1307, USA.
+
+
+
 #                                               -*- Autoconf -*-
 # Process this file with autoconf to produce a configure script.
 
 AC_PREREQ(2.57)
 AC_INIT(FULL-PACKAGE-NAME, VERSION, BUG-REPORT-ADDRESS)
-AM_INIT_AUTOMAKE(LinuxTraceToolkit,0.9.7-29052003)
-AC_CONFIG_HEADER([config.h])
-AC_PROG_LIBTOOL
+#AC_WITH_LTDL  # not needed ?
+AM_INIT_AUTOMAKE(LinuxTraceToolkit,0.9.7-30092003)
+AM_CONFIG_HEADER(config.h)
 AM_PROG_LIBTOOL
 
+AM_PATH_GLIB_2_0(2.0.0, ,AC_MSG_ERROR([glib is required in order to compile LinuxTraceToolkit - download it from ftp://ftp.gtk.org/pub/gtk]) , gmodule)
+
+AM_PATH_GTK_2_0(2.0.0, ,AC_MSG_ERROR([gtk is required in order to compile GUI - download it from ftp://ftp.gtk.org/pub/gtk]) , gmodule)
+
 # Checks for programs.
 AC_PROG_CC
 
 # Checks for libraries.
-AC_CHECK_LIB([popt], [poptGetNextOpt])
-AC_CHECK_LIB([gmodule-2.0], [g_module_open])
-AC_CHECK_LIB([dl], [dlopen])
-AC_CHECK_LIB([glib-2.0], [g_malloc])
+AC_CHECK_LIB([popt], [poptGetNextOpt], ,AC_MSG_ERROR([libpopt is required in order to compile LinuxTraceToolkit])  )
 
 # Checks for header files.
 AC_HEADER_STDC
 AC_CHECK_HEADERS([fcntl.h stdlib.h string.h sys/time.h unistd.h])
 
+AC_ISC_POSIX
+AC_PROG_CC
+AM_PROG_CC_STDC
+AC_HEADER_STDC
+
+pkg_modules="gtk+-2.0 >= 2.0.0"
+PKG_CHECK_MODULES(PACKAGE, [$pkg_modules])
+AC_SUBST(PACKAGE_CFLAGS)
+AC_SUBST(PACKAGE_LIBS)
+
 # Checks for typedefs, structures, and compiler characteristics.
 AC_HEADER_STDBOOL
 AC_C_CONST
@@ -37,22 +67,52 @@ AC_CHECK_FUNCS([select])
 
 #CPPFLAGS="$CPPFLAGS -I"
 
-lttvplugindir="${libdir}/lttv/plugins"
+AM_CONDITIONAL(LTTVSTATIC, test "$enable_lttvstatic" = yes)
+lttvlibdir="${libdir}/lttv"
+AC_SUBST(lttvlibdir)
+
+lttvplugindir="${lttvlibdir}/plugins"
 AC_SUBST(lttvplugindir)
 
-#DEFAULT_INCLUDES="-I\$(top_srcdir)/include"
-#AC_SUBST(DEFAULT_INCLUDES)
+lttlibdir="${libdir}/ltt"
+AC_SUBST(lttlibdir)
 
-lttvincludedir="${includedir}/lttv"
-AC_SUBST(lttvincludedir)
+
+top_lttvdir="\$(top_srcdir)/lttv"
+AC_SUBST(top_lttvdir)
+
+top_lttvwindowdir="\$(top_srcdir)/lttv/modules/gui/lttvwindow"
+AC_SUBST(top_lttvwindowdir)
+
+DEFAULT_INCLUDES="-I\$(top_srcdir) -I\$(top_lttvdir) -I\$(top_lttvwindowdir)"
+AC_SUBST(DEFAULT_INCLUDES)
+
+#CPPFLAGS="${GLIB_CFLAGS}"
+#AC_SUBST(CPPFLAGS)
 
 lttincludedir="${includedir}/ltt"
 AC_SUBST(lttincludedir)
 
+lttvincludedir="${includedir}/lttv"
+AC_SUBST(lttvincludedir)
+
+lttvwindowincludedir="${includedir}/lttvwindow"
+AC_SUBST(lttvwindowincludedir)
+
 AC_CONFIG_FILES([Makefile
-                 lttv/Makefile
-                 lttv/plugins/Makefile
-                lttv/plugins/exemples/Makefile
+                lttv/Makefile
+                lttv/lttv/Makefile
+                lttv/modules/Makefile
+                lttv/modules/text/Makefile
+                lttv/modules/gui/Makefile
+                lttv/modules/gui/lttvwindow/Makefile
+                lttv/modules/gui/lttvwindow/lttvwindow/Makefile
+                lttv/modules/gui/lttvwindow/pixmaps/Makefile
+                lttv/modules/gui/lttvwindow/glade/Makefile
+                lttv/modules/gui/controlflow/Makefile
+                lttv/modules/gui/detailedevents/Makefile
+                lttv/modules/gui/statistics/Makefile
                 lttd/Makefile
-                ltt/Makefile])
+                ltt/Makefile
+                ltt/convert/Makefile])
 AC_OUTPUT
This page took 0.025679 seconds and 4 git commands to generate.