Add a test script to do profiling. Some cleaning as well.
[lttv.git] / ltt / branches / poly / configure.in
index 9891d07a9f37c9fffa8802491234f5c3a9e1915e..bdbc2e8affa130fa42349f230a263f13a9c51d9c 100644 (file)
@@ -1,11 +1,30 @@
+# This file is part of the Linux Trace Toolkit viewer
+# Copyright (C) 2003-2004 Mathieu Desnoyers
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License Version 2 as
+# published by the Free Software Foundation;
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, 
+# MA 02111-1307, USA.
+
+
+
 #                                               -*- Autoconf -*-
 # Process this file with autoconf to produce a configure script.
 
 AC_PREREQ(2.57)
 AC_INIT(FULL-PACKAGE-NAME, VERSION, BUG-REPORT-ADDRESS)
 #AC_WITH_LTDL  # not needed ?
-AM_INIT_AUTOMAKE(LinuxTraceToolkit,0.9.7-06082003)
-AM_CONFIG_HEADER([config.h])
+AM_INIT_AUTOMAKE(LinuxTraceToolkit,0.9.7-30092003)
+AM_CONFIG_HEADER(config.h)
 AM_PROG_LIBTOOL
 
 AM_PATH_GLIB_2_0(2.0.0, ,AC_MSG_ERROR([glib is required in order to compile LinuxTraceToolkit - download it from ftp://ftp.gtk.org/pub/gtk]) , gmodule)
@@ -48,43 +67,52 @@ AC_CHECK_FUNCS([select])
 
 #CPPFLAGS="$CPPFLAGS -I"
 
-lttvplugindir="${libdir}/lttv/plugins"
+AM_CONDITIONAL(LTTVSTATIC, test "$enable_lttvstatic" = yes)
+lttvlibdir="${libdir}/lttv"
+AC_SUBST(lttvlibdir)
+
+lttvplugindir="${lttvlibdir}/plugins"
 AC_SUBST(lttvplugindir)
 
 lttlibdir="${libdir}/ltt"
 AC_SUBST(lttlibdir)
 
 
-top_includedir="\$(top_srcdir)/include"
-AC_SUBST(top_includedir)
+top_lttvdir="\$(top_srcdir)/lttv"
+AC_SUBST(top_lttvdir)
+
+top_lttvwindowdir="\$(top_srcdir)/lttv/modules/gui/lttvwindow"
+AC_SUBST(top_lttvwindowdir)
 
-DEFAULT_INCLUDES="-I\$(top_includedir)"
+DEFAULT_INCLUDES="-I\$(top_srcdir) -I\$(top_lttvdir) -I\$(top_lttvwindowdir)"
 AC_SUBST(DEFAULT_INCLUDES)
 
 #CPPFLAGS="${GLIB_CFLAGS}"
 #AC_SUBST(CPPFLAGS)
 
+lttincludedir="${includedir}/ltt"
+AC_SUBST(lttincludedir)
+
 lttvincludedir="${includedir}/lttv"
 AC_SUBST(lttvincludedir)
 
-lttincludedir="${includedir}/ltt"
-AC_SUBST(lttincludedir)
+lttvwindowincludedir="${includedir}/lttvwindow"
+AC_SUBST(lttvwindowincludedir)
 
 AC_CONFIG_FILES([Makefile
-     lttv/Makefile
+                lttv/Makefile
+                lttv/lttv/Makefile
                 lttv/modules/Makefile
+                lttv/modules/text/Makefile
+                lttv/modules/gui/Makefile
+                lttv/modules/gui/lttvwindow/Makefile
+                lttv/modules/gui/lttvwindow/lttvwindow/Makefile
+                lttv/modules/gui/lttvwindow/pixmaps/Makefile
+                lttv/modules/gui/lttvwindow/glade/Makefile
+                lttv/modules/gui/controlflow/Makefile
+                lttv/modules/gui/detailedevents/Makefile
+                lttv/modules/gui/statistics/Makefile
                 lttd/Makefile
                 ltt/Makefile
-                include/Makefile
-                include/ltt/Makefile
-                ltt/convert/Makefile
-                include/lttv/Makefile])
+                ltt/convert/Makefile])
 AC_OUTPUT
-#               lttv/modules/examples/Makefile
-#               include/ltt/convert/Makefile
-#               lttv/modules/gui/API/Makefile
-#               lttv/modules/gui/Makefile
-#               lttv/modules/text/Makefile
-#               lttv/plugins/Makefile
-#               lttv/plugins/examples/Makefile
-#               lttv/modules/coreGUI/Makefile
This page took 0.023594 seconds and 4 git commands to generate.