Add a test script to do profiling. Some cleaning as well.
[lttv.git] / ltt / branches / poly / configure.in
index 47baf9d23fb5a67f68dcc6fee7314fece2bbcbbc..bdbc2e8affa130fa42349f230a263f13a9c51d9c 100644 (file)
@@ -67,6 +67,7 @@ AC_CHECK_FUNCS([select])
 
 #CPPFLAGS="$CPPFLAGS -I"
 
+AM_CONDITIONAL(LTTVSTATIC, test "$enable_lttvstatic" = yes)
 lttvlibdir="${libdir}/lttv"
 AC_SUBST(lttvlibdir)
 
@@ -77,39 +78,41 @@ lttlibdir="${libdir}/ltt"
 AC_SUBST(lttlibdir)
 
 
-top_includedir="\$(top_srcdir)/include"
-AC_SUBST(top_includedir)
+top_lttvdir="\$(top_srcdir)/lttv"
+AC_SUBST(top_lttvdir)
 
-DEFAULT_INCLUDES="-I\$(top_includedir) -I\$(top_srcdir)"
+top_lttvwindowdir="\$(top_srcdir)/lttv/modules/gui/lttvwindow"
+AC_SUBST(top_lttvwindowdir)
+
+DEFAULT_INCLUDES="-I\$(top_srcdir) -I\$(top_lttvdir) -I\$(top_lttvwindowdir)"
 AC_SUBST(DEFAULT_INCLUDES)
 
 #CPPFLAGS="${GLIB_CFLAGS}"
 #AC_SUBST(CPPFLAGS)
 
+lttincludedir="${includedir}/ltt"
+AC_SUBST(lttincludedir)
+
 lttvincludedir="${includedir}/lttv"
 AC_SUBST(lttvincludedir)
 
-lttincludedir="${includedir}/ltt"
-AC_SUBST(lttincludedir)
+lttvwindowincludedir="${includedir}/lttvwindow"
+AC_SUBST(lttvwindowincludedir)
 
 AC_CONFIG_FILES([Makefile
                 lttv/Makefile
-                lttv/main/Makefile
+                lttv/lttv/Makefile
                 lttv/modules/Makefile
                 lttv/modules/text/Makefile
                 lttv/modules/gui/Makefile
-                lttv/modules/gui/mainlib/Makefile
-                lttv/modules/gui/main/Makefile
-                lttv/modules/gui/main/src/Makefile
-                lttv/modules/gui/main/pixmaps/Makefile
-                lttv/modules/gui/icons/Makefile
+                lttv/modules/gui/lttvwindow/Makefile
+                lttv/modules/gui/lttvwindow/lttvwindow/Makefile
+                lttv/modules/gui/lttvwindow/pixmaps/Makefile
+                lttv/modules/gui/lttvwindow/glade/Makefile
                 lttv/modules/gui/controlflow/Makefile
                 lttv/modules/gui/detailedevents/Makefile
                 lttv/modules/gui/statistics/Makefile
                 lttd/Makefile
                 ltt/Makefile
-                include/Makefile
-                include/ltt/Makefile
-                ltt/convert/Makefile
-                include/lttv/Makefile])
+                ltt/convert/Makefile])
 AC_OUTPUT
This page took 0.022746 seconds and 4 git commands to generate.