configure: add '-Wredundant-decls' to warning flags
[lttng-tools.git] / tests / utils / testapp / gen-ust-nevents / Makefile.am
index 6788b1f363696f9f7827c9583bcdae04ea8d9011..c2d36d7c951c370fe13ffc6d9a1eb518a9ac790a 100644 (file)
@@ -4,9 +4,18 @@ AM_CPPFLAGS += -I$(srcdir) -I$(top_srcdir)/tests/utils \
        -I$(top_srcdir)/tests/utils/testapp
 
 if HAVE_LIBLTTNG_UST_CTL
+WARN_FLAGS = \
+       -Wno-redundant-decls
+
+AM_CFLAGS += $(WARN_FLAGS)
+AM_CXXFLAGS += $(WARN_FLAGS)
+
 noinst_PROGRAMS = gen-ust-nevents
-gen_ust_nevents_SOURCES = gen-ust-nevents.c tp.c tp.h
-gen_ust_nevents_LDADD = $(UST_LIBS) $(URCU_BP_LIBS) \
+gen_ust_nevents_SOURCES = \
+       gen-ust-nevents.cpp \
+       tp.c \
+       tp.h
+gen_ust_nevents_LDADD = $(UST_LIBS) \
                $(top_builddir)/tests/utils/libtestutils.la \
                $(DL_LIBS)
 endif
This page took 0.028985 seconds and 4 git commands to generate.