configure: add '-Wredundant-decls' to warning flags
[lttng-tools.git] / tests / utils / testapp / gen-ust-events / Makefile.am
index c05c665a1e0127a3616057e649f73cebb0bd5f34..1e89ddd67b0d8d72e47917f68a34bb2bcbea1404 100644 (file)
@@ -4,6 +4,13 @@ AM_CPPFLAGS += -I$(top_srcdir)/tests/utils -I$(srcdir) \
        -I$(top_srcdir)/tests/utils/testapp
 
 if HAVE_LIBLTTNG_UST_CTL
+# Disable some warnings flags to accomodate the tracepoint headers
+WARN_FLAGS = \
+       -Wno-redundant-decls
+
+AM_CFLAGS += $(WARN_FLAGS)
+AM_CXXFLAGS += $(WARN_FLAGS)
+
 noinst_PROGRAMS = gen-ust-events
 gen_ust_events_SOURCES = \
        gen-ust-events.cpp \
This page took 0.023113 seconds and 4 git commands to generate.