configure: add '-Wredundant-decls' to warning flags
[lttng-tools.git] / tests / utils / testapp / gen-ust-events-ns / Makefile.am
index ad9203c4e9bbd8e630de74a912217f2055e47957..37bdc94fe786f3c7bfb2e1420e40ea1377b563ca 100644 (file)
@@ -1,9 +1,21 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AM_CPPFLAGS += -I$(top_srcdir)/tests/utils -I$(srcdir) \
               -I$(top_srcdir)/tests/utils/testapp
 
 if HAVE_LIBLTTNG_UST_CTL
+# Disable some warnings flags to accomodate the tracepoint headers
+WARN_FLAGS = \
+       -Wno-redundant-decls
+
+AM_CFLAGS += $(WARN_FLAGS)
+AM_CXXFLAGS += $(WARN_FLAGS)
+
 noinst_PROGRAMS = gen-ust-events-ns
-gen_ust_events_ns_SOURCES = gen-ust-events-ns.c tp.c tp.h
+gen_ust_events_ns_SOURCES = \
+       gen-ust-events-ns.cpp \
+       tp.c \
+       tp.h
 gen_ust_events_ns_LDADD = $(UST_LIBS) -llttng-ust-fork \
                $(top_builddir)/tests/utils/libtestutils.la \
                $(DL_LIBS) $(POPT_LIBS)
This page took 0.027408 seconds and 4 git commands to generate.