lttng-ctl: Introduce lttng_log_level_rule
[lttng-tools.git] / tests / unit / Makefile.am
index 498a4a623b7a26af2093712eafd99d007d9e5a62..6d33beafb6cb03d6efdec2cb7a43c0d62865602f 100644 (file)
@@ -17,6 +17,7 @@ TESTS = \
        test_fd_tracker \
        test_kernel_data \
        test_kernel_probe \
+       test_log_level_rule \
        test_notification \
        test_payload \
        test_relayd_backward_compat_group_by_session \
@@ -42,19 +43,29 @@ LIBRELAYD=$(top_builddir)/src/common/relayd/librelayd.la
 LIBLTTNG_CTL=$(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
 
 # Define test programs
-noinst_PROGRAMS = test_uri test_session test_kernel_data \
-                  test_utils_parse_size_suffix test_utils_parse_time_suffix \
-                  test_utils_expand_path test_utils_compat_poll test_utils_compat_pthread \
-                  test_string_utils test_notification test_directory_handle \
-                  test_relayd_backward_compat_group_by_session \
-                  test_fd_tracker test_uuid \
-                  test_buffer_view \
-                  test_payload \
-                  test_unix_socket \
-                  test_kernel_probe \
-                  test_condition \
-                 test_event_expr_to_bytecode \
-                  test_event_rule 
+noinst_PROGRAMS = \
+       test_buffer_view \
+       test_condition \
+       test_directory_handle \
+       test_event_expr_to_bytecode \
+       test_event_rule \
+       test_fd_tracker \
+       test_kernel_data \
+       test_kernel_probe \
+       test_log_level_rule \
+       test_notification \
+       test_payload \
+       test_relayd_backward_compat_group_by_session \
+       test_session \
+       test_string_utils \
+       test_unix_socket \
+       test_uri \
+       test_utils_compat_poll \
+       test_utils_compat_pthread \
+       test_utils_expand_path \
+       test_utils_parse_size_suffix \
+       test_utils_parse_time_suffix \
+       test_uuid
 
 if HAVE_LIBLTTNG_UST_CTL
 noinst_PROGRAMS += test_ust_data
@@ -245,3 +256,7 @@ test_kernel_probe_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBLTTNG_CTL) $(DL_LIBS)
 # Event expression to bytecode test
 test_event_expr_to_bytecode_SOURCES = test_event_expr_to_bytecode.c
 test_event_expr_to_bytecode_LDADD = $(LIBTAP) $(LIBLTTNG_CTL) $(LIBCOMMON)
+
+# Log level rule api
+test_log_level_rule_SOURCES = test_log_level_rule.c
+test_log_level_rule_LDADD = $(LIBTAP) $(LIBCOMMON) $(LIBLTTNG_CTL) $(DL_LIBS)
This page took 0.023584 seconds and 4 git commands to generate.