configure: add '-Wredundant-decls' to warning flags
[lttng-tools.git] / tests / regression / ust / ust-dl / Makefile.am
index 9889e85a49ad1b3179dfbd12d9eeb2a5946d538a..366b02bb0eb9daf13e10847a77e00bd8cee653cc 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 if NO_SHARED
 # Do not build this test if shared libraries support was
 # explicitly disabled.
@@ -17,9 +19,13 @@ objcopy_verbose_0 = @echo "  OBJCOPY " $@;
 
 AM_CPPFLAGS += -I$(srcdir) -g
 
+# Disable some warnings flags to accomodate the tracepoint headers
+AM_CFLAGS += \
+       -Wno-redundant-decls
+
 noinst_PROGRAMS = prog
 prog_SOURCES = prog.c
-prog_LDADD = -ldl
+prog_LDADD = $(DL_LIBS)
 
 noinst_LTLIBRARIES = libzzz.la libbar.la libfoo.la libtp.la
 
This page took 0.023538 seconds and 4 git commands to generate.