configure: add '-Wredundant-decls' to warning flags
[lttng-tools.git] / tests / regression / ust / ust-dl / Makefile.am
index 315a995afdf512a26b448b7d2988a8f90e2fa692..366b02bb0eb9daf13e10847a77e00bd8cee653cc 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 if NO_SHARED
 # Do not build this test if shared libraries support was
 # explicitly disabled.
@@ -17,9 +19,13 @@ objcopy_verbose_0 = @echo "  OBJCOPY " $@;
 
 AM_CPPFLAGS += -I$(srcdir) -g
 
+# Disable some warnings flags to accomodate the tracepoint headers
+AM_CFLAGS += \
+       -Wno-redundant-decls
+
 noinst_PROGRAMS = prog
 prog_SOURCES = prog.c
-prog_LDADD = -ldl
+prog_LDADD = $(DL_LIBS)
 
 noinst_LTLIBRARIES = libzzz.la libbar.la libfoo.la libtp.la
 
@@ -67,7 +73,7 @@ libtp.so: libtp.la
        @cp -f .libs/libtp.so libtp.so
 
 noinst_SCRIPTS = test_ust-dl test_ust-dl.py
-EXTRA_DIST = test_ust-dl test_ust-dl.py
+EXTRA_DIST = test_ust-dl.py
 
 all-local: libfoo.so libbar.so libzzz.so libtp.so
        @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
This page took 0.022898 seconds and 4 git commands to generate.