configure: add '-Wredundant-decls' to warning flags
[lttng-tools.git] / tests / regression / ust / type-declarations / Makefile.am
index dd4eda26bfba225dffd8102e06c97b9017732a61..64bb56ce1f77b322d664ac9bf9267bd0053b595c 100644 (file)
@@ -1,5 +1,11 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AM_CPPFLAGS += -I$(srcdir)
 
+# Disable some warnings flags to accomodate the tracepoint headers
+AM_CFLAGS += \
+       -Wno-redundant-decls
+
 noinst_PROGRAMS = type-declarations
 type_declarations_SOURCES = type-declarations.c ust_tests_td.h
 type_declarations_LDADD = $(UST_LIBS) $(DL_LIBS)
This page took 0.026603 seconds and 4 git commands to generate.