configure: add '-Wredundant-decls' to warning flags
[lttng-tools.git] / tests / regression / ust / overlap / demo / Makefile.am
index 348adbe903acc70884887c827233699b9e534685..dbdf266e04459d57ba68aec344044e47e98c04f9 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 if NO_SHARED
 # Do not build this test if shared libraries support was
 # explicitly disabled.
@@ -12,6 +14,10 @@ else
 
 AM_CPPFLAGS += -I$(srcdir)
 
+# Disable some warnings flags to accomodate the tracepoint headers
+AM_CFLAGS += \
+       -Wno-redundant-decls
+
 # Force the shared flag on the noinst libraries since they are
 # only built static by default
 FORCE_SHARED_LIB_OPTIONS = -module -shared -avoid-version \
This page took 0.024231 seconds and 4 git commands to generate.