configure: add '-Wredundant-decls' to warning flags
[lttng-tools.git] / tests / regression / ust / multi-session / Makefile.am
index 204ae7bcf2f96cb28a61725b3215cf254dc4de4e..aaaf2ff0413a86ff34283d34ac454944bf79a451 100644 (file)
@@ -1,8 +1,14 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AM_CFLAGS += -I$(srcdir)
 
+# Disable some warnings flags to accomodate the tracepoint headers
+AM_CFLAGS += \
+       -Wno-redundant-decls
+
 noinst_PROGRAMS = gen-nevents
 gen_nevents_SOURCES = gen-nevents.c tp.c ust_gen_nevents.h
-gen_nevents_LDADD = -llttng-ust -lurcu-bp $(DL_LIBS)
+gen_nevents_LDADD = $(UST_LIBS) $(DL_LIBS)
 
 noinst_SCRIPTS = test_multi_session
 EXTRA_DIST = test_multi_session
This page took 0.027228 seconds and 4 git commands to generate.