configure: add '-Wredundant-decls' to warning flags
[lttng-tools.git] / tests / regression / ust / multi-lib / Makefile.am
index 0ce46a7ffe376ce53094120a03085974fe561d20..7fdcb8ac1acdfc03fb9ba87dd9e8ad00fc2951cb 100644 (file)
@@ -1,13 +1,19 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
+# Disable some warnings flags to accomodate the tracepoint headers
+AM_CFLAGS += \
+       -Wno-redundant-decls
+
 noinst_SCRIPTS = test_multi_lib
 EXTRA_DIST = test_multi_lib
 noinst_PROGRAMS = exec-with-callsites exec-without-callsites
 
 exec_with_callsites_SOURCES = multi-lib-test.c callsites.c
-exec_with_callsites_LDFLAGS = -ldl $(POPT_LIBS)
+exec_with_callsites_LDFLAGS = $(DL_LIBS) $(POPT_LIBS)
 exec_with_callsites_CFLAGS = $(POPT_CFLAGS) $(AM_CFLAGS) -DHAS_CALLSITES=1
 
 exec_without_callsites_SOURCES = multi-lib-test.c
-exec_without_callsites_LDFLAGS = -ldl $(POPT_LIBS) $(UST_LIBS)
+exec_without_callsites_LDFLAGS = $(DL_LIBS) $(POPT_LIBS) $(UST_LIBS)
 exec_without_callsites_LDADD = probes.o
 exec_without_callsites_CFLAGS = $(POPT_CFLAGS) $(AM_CFLAGS) -DHAS_CALLSITES=0
 
This page took 0.023213 seconds and 4 git commands to generate.