configure: add '-Wredundant-decls' to warning flags
[lttng-tools.git] / tests / regression / ust / linking / Makefile.am
index bf0a517ad3b33b48ca69ff17b9a91a527dafb868..5edcb9374b5283d8def88a8022b71318f4f1424a 100644 (file)
@@ -2,7 +2,14 @@
 
 # -Wsystem-headers is needed to print warnings in the tracepoint
 # description file.
-AM_CPPFLAGS += -I$(srcdir) -Wsystem-headers
+#
+# However, we see some -Wformat-nonliteral warnings in some system headers,
+# so disable that.
+AM_CPPFLAGS += -I$(srcdir) -Wsystem-headers -Wno-format-nonliteral
+
+# Disable some warnings flags to accomodate the tracepoint headers
+AM_CFLAGS += \
+       -Wno-redundant-decls
 
 # Set LIBS to nothing so the application does not link on useless
 # libraries.
This page took 0.023857 seconds and 4 git commands to generate.