configure: add '-Wredundant-decls' to warning flags
[lttng-tools.git] / tests / regression / ust / high-throughput / Makefile.am
index 22a31e18b062df7f43b6ec27e08199e2fc09dda0..10863365185909d445e725806b21db149f1a9408 100644 (file)
@@ -1,15 +1,14 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AM_CPPFLAGS += -I$(srcdir)
 
-if LTTNG_TOOLS_BUILD_WITH_LIBDL
-LIBS += -ldl
-endif
-if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-LIBS += -lc
-endif
+# Disable some warnings flags to accomodate the tracepoint headers
+AM_CFLAGS += \
+       -Wno-redundant-decls
 
 noinst_PROGRAMS = gen-events
 gen_events_SOURCES = main.c tp.c tp.h
-gen_events_LDADD = -llttng-ust
+gen_events_LDADD = $(UST_LIBS) $(DL_LIBS)
 
 noinst_SCRIPTS = test_high_throughput
 EXTRA_DIST = test_high_throughput
This page took 0.024844 seconds and 4 git commands to generate.