configure: add '-Wredundant-decls' to warning flags
[lttng-tools.git] / tests / regression / ust / exit-fast / Makefile.am
index 539803d7beb82fcd995345cd88867d03211847bd..30f05966be72102c915f3276fc3111006f70b269 100644 (file)
@@ -1,15 +1,14 @@
-AM_CPPFLAGS = -I$(srcdir)
+# SPDX-License-Identifier: GPL-2.0-only
+
+AM_CPPFLAGS += -I$(srcdir)
+
+# Disable some warnings flags to accomodate the tracepoint headers
+AM_CFLAGS += \
+       -Wno-redundant-decls
 
 noinst_PROGRAMS = exit-fast
 exit_fast_SOURCES = exit-fast.c ust_tests_exitfast.h
-exit_fast_LDADD = -llttng-ust
-
-if LTTNG_TOOLS_BUILD_WITH_LIBDL
-exit_fast_LDADD += -ldl
-endif
-if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-exit_fast_LDADD += -lc
-endif
+exit_fast_LDADD = $(UST_LIBS) $(DL_LIBS)
 
 noinst_SCRIPTS = test_exit-fast test_exit-fast.py
 EXTRA_DIST = test_exit-fast test_exit-fast.py
This page took 0.023546 seconds and 4 git commands to generate.