configure: add '-Wredundant-decls' to warning flags
[lttng-tools.git] / tests / regression / ust / daemon / Makefile.am
index 76a34ef07eb7cb41a4919dd0eb6ebfd1bd963e45..48806e1b6c999ab360d0593695caa17bf987786d 100644 (file)
@@ -1,15 +1,14 @@
-AM_CPPFLAGS = -I$(srcdir)
+# SPDX-License-Identifier: GPL-2.0-only
+
+AM_CPPFLAGS += -I$(srcdir)
+
+# Disable some warnings flags to accomodate the tracepoint headers
+AM_CFLAGS += \
+       -Wno-redundant-decls
 
 noinst_PROGRAMS = daemon
 daemon_SOURCES = daemon.c ust_tests_daemon.h
-daemon_LDADD = -llttng-ust -llttng-ust-fork
-
-if LTTNG_TOOLS_BUILD_WITH_LIBDL
-daemon_LDADD += -ldl
-endif
-if LTTNG_TOOLS_BUILD_WITH_LIBC_DL
-daemon_LDADD += -lc
-endif
+daemon_LDADD = $(UST_LIBS) -llttng-ust-fork $(DL_LIBS)
 
 noinst_SCRIPTS = test_daemon test_daemon.py
 EXTRA_DIST = test_daemon test_daemon.py
This page took 0.023224 seconds and 4 git commands to generate.