configure: add '-Wredundant-decls' to warning flags
[lttng-tools.git] / tests / regression / ust / daemon / Makefile.am
index 632f131d89f92d5790849c7d87360e367789c1c1..48806e1b6c999ab360d0593695caa17bf987786d 100644 (file)
@@ -1,5 +1,11 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 AM_CPPFLAGS += -I$(srcdir)
 
+# Disable some warnings flags to accomodate the tracepoint headers
+AM_CFLAGS += \
+       -Wno-redundant-decls
+
 noinst_PROGRAMS = daemon
 daemon_SOURCES = daemon.c ust_tests_daemon.h
 daemon_LDADD = $(UST_LIBS) -llttng-ust-fork $(DL_LIBS)
This page took 0.022661 seconds and 4 git commands to generate.