configure: add '-Wredundant-decls' to warning flags
[lttng-tools.git] / tests / regression / ust / baddr-statedump / Makefile.am
index 7caf457661a38471037d49ede663d9840f297824..f8fe263955ee18b51b906c1fb93545b403933a5e 100644 (file)
@@ -1,12 +1,18 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
 objcopy_verbose = $(objcopy_verbose_@AM_V@)
 objcopy_verbose_ = $(objcopy_verbose_@AM_DEFAULT_V@)
 objcopy_verbose_0 = @echo OBJCOPY $@;
 
-AM_CPPFLAGS = -I$(srcdir) -g
+AM_CPPFLAGS += -I$(srcdir) -g
+
+# Disable some warnings flags to accomodate the tracepoint headers
+AM_CFLAGS += \
+       -Wno-redundant-decls
 
 noinst_PROGRAMS = prog
 prog_SOURCES = prog.c tp.c tp.h
-prog_LDADD = -llttng-ust -ldl
+prog_LDADD = $(UST_LIBS) $(DL_LIBS)
 
 noinst_SCRIPTS = test_baddr-statedump test_baddr-statedump.py
 EXTRA_DIST = test_baddr-statedump test_baddr-statedump.py
This page took 0.027474 seconds and 4 git commands to generate.