src/common: use single Makefile for parallel builds
[lttng-tools.git] / tests / regression / tools / trigger / utils / Makefile.am
index 4b716cadbe5ff76d053720d99ff77a1b11530309..a6a0258d4188df730f16bb18e73ad67ad8ae7e7a 100644 (file)
@@ -1,9 +1,17 @@
 # SPDX-License-Identifier: GPL-2.0-only
 
-AM_CFLAGS += -I$(srcdir) -I$(top_srcdir)/tests/utils
+AM_CPPFLAGS += -I$(srcdir) -I$(top_srcdir)/tests/utils
 LIBLTTNG_CTL=$(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la
 
-noinst_PROGRAMS = notification-client
+noinst_PROGRAMS = \
+       notification-client \
+       register-some-triggers
+
 notification_client_SOURCES = notification-client.c
 notification_client_LDADD = $(LIBLTTNG_CTL) \
-               $(top_builddir)/tests/utils/libtestutils.la
+       $(top_builddir)/tests/utils/libtestutils.la
+
+register_some_triggers_SOURCES = register-some-triggers.cpp
+register_some_triggers_LDADD = $(LIBLTTNG_CTL) \
+       $(top_builddir)/src/common/libfilter.la \
+       $(top_builddir)/src/common/libbytecode.la
This page took 0.026367 seconds and 4 git commands to generate.