Tests: add kernel test into the `make check` test suite.
[lttng-tools.git] / tests / regression / Makefile.am
index b066149652fdb319d3d1a4e69fa32a46ae282b37..74a4c48f148067c7e205b83a89e99c2e20e51a37 100644 (file)
@@ -4,9 +4,11 @@ SUBDIRS = tools kernel ust
 
 LOG_DRIVER_FLAGS = --merge --post-script $(top_srcdir)/tests/utils/warn_processes.sh
 LOG_DRIVER = env PGREP='$(PGREP)' AM_TAP_AWK='$(AWK)' $(SHELL) \
-       $(top_srcdir)/config/tap-driver.sh
+       $(top_srcdir)/tests/utils/tap-driver.sh
 
-TESTS = tools/filtering/test_invalid_filter \
+TESTS = tools/base-path/test_ust \
+       tools/channel/test_channel \
+       tools/filtering/test_invalid_filter \
        tools/filtering/test_unsupported_op \
        tools/filtering/test_valid_filter \
        tools/streaming/test_ust \
@@ -29,8 +31,15 @@ TESTS = tools/filtering/test_invalid_filter \
        tools/regen-statedump/test_ust \
        tools/notification/test_notification_ust_error \
        tools/notification/test_notification_ust_buffer_usage \
+       tools/notification/test_notification_ust_capture \
+       tools/notification/test_notification_ust_event_rule_condition_exclusion \
        tools/notification/test_notification_kernel_error \
        tools/notification/test_notification_kernel_buffer_usage \
+       tools/notification/test_notification_kernel_capture \
+       tools/notification/test_notification_kernel_instrumentation \
+       tools/notification/test_notification_kernel_syscall \
+       tools/notification/test_notification_notifier_discarded_count \
+       tools/notification/test_notification_kernel_userspace_probe \
        tools/notification/test_notification_multi_app \
        tools/rotation/test_ust \
        tools/rotation/test_kernel \
@@ -38,13 +47,15 @@ TESTS = tools/filtering/test_invalid_filter \
        tools/rotation/test_schedule_api \
        tools/metadata/test_kernel \
        tools/working-directory/test_relayd_working_directory \
-       tools/notification/test_notification_multi_app \
        tools/clear/test_ust \
        tools/clear/test_kernel \
        tools/tracker/test_event_tracker \
+       tools/trigger/start-stop/test_start_stop \
        tools/trigger/test_add_trigger_cli \
        tools/trigger/test_list_triggers_cli \
-       tools/trigger/test_remove_trigger_cli
+       tools/trigger/test_remove_trigger_cli \
+       tools/trigger/name/test_trigger_name_backwards_compat \
+       tools/trigger/hidden/test_hidden_trigger
 
 if HAVE_LIBLTTNG_UST_CTL
 SUBDIRS += ust
@@ -65,10 +76,24 @@ TESTS += ust/before-after/test_before_after \
        ust/multi-lib/test_multi_lib \
        ust/rotation-destroy-flush/test_rotation_destroy_flush \
        tools/metadata/test_ust \
-       tools/relayd-grouping/test_ust
+       tools/relayd-grouping/test_ust \
+       tools/trigger/rate-policy/test_ust_rate_policy
 
 if IS_LINUX
 TESTS += \
+       kernel/test_all_events \
+       kernel/test_callstack \
+       kernel/test_channel \
+       kernel/test_clock_override \
+       kernel/test_event_basic \
+       kernel/test_kernel_function \
+       kernel/test_lttng_logger \
+       kernel/test_ns_contexts \
+       kernel/test_ns_contexts_change \
+       kernel/test_rotation_destroy_flush \
+       kernel/test_select_poll_epoll \
+       kernel/test_syscall \
+       kernel/test_userspace_probe \
        ust/namespaces/test_ns_contexts \
        ust/namespaces/test_ns_contexts_change
 endif # IS_LINUX
This page took 0.026156 seconds and 4 git commands to generate.