Fix: missing RCU read side critical sections
[lttng-tools.git] / src / common / ust-consumer / Makefile.am
index ab8d38add5fc1fe5b3608ceee8446c9cfce4e7a0..5e100537209ffc8e03af71e5c02fb9009612ada6 100644 (file)
@@ -1,13 +1,13 @@
-if HAVE_LIBLTTNG_UST_CTL
+# SPDX-License-Identifier: GPL-2.0-only
 
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src
+if HAVE_LIBLTTNG_UST_CTL
 
 noinst_LTLIBRARIES = libust-consumer.la
 
-libust_consumer_la_SOURCES = ust-consumer.c ust-consumer.h
+libust_consumer_la_SOURCES = \
+       ust-consumer.cpp \
+       ust-consumer.h
 
-libust_consumer_la_LIBADD = \
-                       -llttng-ust-ctl \
-                       $(top_builddir)/src/common/relayd/librelayd.la
+libust_consumer_la_LIBADD = $(UST_CTL_LIBS)
 
 endif
This page took 0.024549 seconds and 4 git commands to generate.