Fix: missing RCU read side critical sections
[lttng-tools.git] / src / common / hashtable / Makefile.am
index 62e22c117036c6c9fb752893811025687624c6cf..f16b1b513d06a1b0e2bf46013c21e34b571fe86c 100644 (file)
@@ -1,13 +1,17 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src
+# SPDX-License-Identifier: GPL-2.0-only
 
-noinst_LTLIBRARIES = libhashtable.la
+noinst_LTLIBRARIES = libhashtable-gpl.la libhashtable-lgpl.la
 
-libhashtable_la_SOURCES = hashtable.c hashtable.h \
-                         utils.c utils.h \
-                         rculfhash-internal.h urcu-flavor.h \
-                         rculfhash.h rculfhash.c \
-                         rculfhash-mm-chunk.c \
-                         rculfhash-mm-mmap.c \
-                         rculfhash-mm-order.c
+libhashtable_lgpl_la_SOURCES = \
+       seed.cpp \
+       utils.cpp \
+       utils.h
 
-libhashtable_la_LIBADD = -lurcu-common -lurcu
+libhashtable_gpl_la_SOURCES = \
+       hashtable.cpp \
+       hashtable.h \
+       hashtable-symbols.h
+
+libhashtable_gpl_la_LIBADD = \
+       $(URCU_LIBS) \
+       $(URCU_CDS_LIBS)
This page took 0.023971 seconds and 4 git commands to generate.