Fix: missing RCU read side critical sections
[lttng-tools.git] / src / common / compat / Makefile.am
index 91cd3bdcf7bc3237ce39353c9c37f18d06ac252f..0499b356824694fb3aab0e13abff5d98affca013 100644 (file)
@@ -1,12 +1,24 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include
+# SPDX-License-Identifier: GPL-2.0-only
 
 noinst_LTLIBRARIES = libcompat.la
 
-if COMPAT_EPOLL
-COMPAT=compat-epoll.c
-else
-COMPAT=compat-poll.c
-endif
-
-libcompat_la_SOURCES = poll.h fcntl.h endian.h mman.h clone.h \
-                       socket.h compat-fcntl.c $(COMPAT)
+libcompat_la_SOURCES = \
+        compat-fcntl.cpp \
+        directory-handle.cpp \
+        directory-handle.h \
+        dirent.h \
+        endian.h \
+        errno.h \
+        fcntl.h \
+        getenv.h \
+        mman.h \
+        netdb.h \
+        path.h \
+        paths.h \
+        poll.cpp \
+        poll.h \
+        pthread.h \
+        socket.h \
+        string.h \
+        tid.h \
+        time.h
This page took 0.024524 seconds and 4 git commands to generate.