Fix: missing RCU read side critical sections
[lttng-tools.git] / src / common / compat / Makefile.am
index 82c74eedf21e371fdd212c4551dad96008570f7a..0499b356824694fb3aab0e13abff5d98affca013 100644 (file)
@@ -1,12 +1,24 @@
-noinst_LTLIBRARIES = libcompat.la
+# SPDX-License-Identifier: GPL-2.0-only
 
-if COMPAT_EPOLL
-COMPAT=compat-epoll.c
-else
-COMPAT=compat-poll.c
-endif
+noinst_LTLIBRARIES = libcompat.la
 
-libcompat_la_SOURCES = poll.h fcntl.h endian.h mman.h dirent.h \
-               socket.h compat-fcntl.c uuid.h uuid.c tid.h \
-               getenv.h string.h prctl.h paths.h netdb.h $(COMPAT) \
-               time.h
+libcompat_la_SOURCES = \
+        compat-fcntl.cpp \
+        directory-handle.cpp \
+        directory-handle.h \
+        dirent.h \
+        endian.h \
+        errno.h \
+        fcntl.h \
+        getenv.h \
+        mman.h \
+        netdb.h \
+        path.h \
+        paths.h \
+        poll.cpp \
+        poll.h \
+        pthread.h \
+        socket.h \
+        string.h \
+        tid.h \
+        time.h
This page took 0.024221 seconds and 4 git commands to generate.