Fix: missing RCU read side critical sections
[lttng-tools.git] / src / common / compat / Makefile.am
index 7cd3f91fc6f8530356cc860f79d88819cd97d880..0499b356824694fb3aab0e13abff5d98affca013 100644 (file)
@@ -1,13 +1,24 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/src
+# SPDX-License-Identifier: GPL-2.0-only
 
 noinst_LTLIBRARIES = libcompat.la
 
-if COMPAT_EPOLL
-COMPAT=compat-epoll.c
-else
-COMPAT=compat-poll.c
-endif
-
-libcompat_la_SOURCES = poll.h fcntl.h endian.h mman.h clone.h \
-               socket.h compat-fcntl.c uuid.h tid.h \
-               getenv.h string.h $(COMPAT)
+libcompat_la_SOURCES = \
+        compat-fcntl.cpp \
+        directory-handle.cpp \
+        directory-handle.h \
+        dirent.h \
+        endian.h \
+        errno.h \
+        fcntl.h \
+        getenv.h \
+        mman.h \
+        netdb.h \
+        path.h \
+        paths.h \
+        poll.cpp \
+        poll.h \
+        pthread.h \
+        socket.h \
+        string.h \
+        tid.h \
+        time.h
This page took 0.025242 seconds and 4 git commands to generate.