Fix: missing RCU read side critical sections
[lttng-tools.git] / src / common / compat / Makefile.am
index 2430fceab5d3b8ce1eb33c0015c63535bba75e67..0499b356824694fb3aab0e13abff5d98affca013 100644 (file)
@@ -2,13 +2,23 @@
 
 noinst_LTLIBRARIES = libcompat.la
 
-if COMPAT_EPOLL
-COMPAT=compat-epoll.c
-else
-COMPAT=compat-poll.c
-endif
-
-libcompat_la_SOURCES = poll.h fcntl.h endian.h mman.h dirent.h \
-               socket.h compat-fcntl.c tid.h \
-               getenv.h string.h prctl.h paths.h netdb.h $(COMPAT) \
-               time.h directory-handle.h directory-handle.c path.h
+libcompat_la_SOURCES = \
+        compat-fcntl.cpp \
+        directory-handle.cpp \
+        directory-handle.h \
+        dirent.h \
+        endian.h \
+        errno.h \
+        fcntl.h \
+        getenv.h \
+        mman.h \
+        netdb.h \
+        path.h \
+        paths.h \
+        poll.cpp \
+        poll.h \
+        pthread.h \
+        socket.h \
+        string.h \
+        tid.h \
+        time.h
This page took 0.025133 seconds and 4 git commands to generate.