Move utils_expand_path and utils_expand_path_keep_symlink to libpath.la
[lttng-tools.git] / src / common / Makefile.am
index 675885a6754c1f45f8916f3fba938dca47ef3881..cb7758b98be9cb668069b0d0efdd06c468839646 100644 (file)
@@ -36,7 +36,7 @@ DIST_SUBDIRS = \
        argpar-utils
 
 # Common library
-noinst_LTLIBRARIES = libcommon-lgpl.la libcommon-gpl.la
+noinst_LTLIBRARIES = libpath.la libcommon-lgpl.la libcommon-gpl.la
 EXTRA_DIST = mi-lttng-4.1.xsd
 
 # The libcommon-lgpl static archive contains only LGPLv2.1 code. It is
@@ -114,6 +114,12 @@ libcommon_lgpl_la_LIBADD = \
        $(top_builddir)/src/common/hashtable/libhashtable-lgpl.la \
        $(top_builddir)/src/vendor/msgpack/libmsgpack.la
 
+# The libpath static archive contains GPLv2 compatible code. It is
+# meant to be used by GPL executables.
+
+libpath_la_SOURCES = \
+       path.c path.h
+
 # The libcommon-gpl static archive contains GPLv2 compatible code. It is
 # meant to be used by GPL executables.
 
@@ -136,6 +142,7 @@ libcommon_gpl_la_SOURCES = \
 
 libcommon_gpl_la_LIBADD = \
        libcommon-lgpl.la \
+       libpath.la \
        $(top_builddir)/src/common/hashtable/libhashtable-gpl.la \
        $(top_builddir)/src/common/fd-tracker/libfd-tracker.la
 
This page took 0.023706 seconds and 4 git commands to generate.