src/common: use single Makefile for parallel builds
[lttng-tools.git] / extras / bindings / swig / python / Makefile.am
index bdecadcae2ef94967e95e44e068ce1ec0ec36f01..15dea077dedce8cb3f99b3c57aa5dc4b7132459f 100644 (file)
@@ -3,6 +3,13 @@
 lttng.i: lttng.i.in
        $(SED) "s/LTTNG_VERSION_STR/LTTng $(PACKAGE_VERSION)/g" < $(srcdir)/lttng.i.in >lttng.i
 
+# Some versions of SWIG (like 3.0.12) generate code where a parameter called
+# `swig_this` shadows a global of the same name.  Later versions (like 4.0.1)
+# have renamed this global to `Swig_This_global`.
+#
+# Disable -Wshadow for that file.
+AM_CFLAGS += -Wno-shadow
+
 AM_CPPFLAGS += $(PYTHON_INCLUDE)
 
 EXTRA_DIST = lttng.i.in
@@ -14,8 +21,8 @@ MAINTAINERCLEANFILES = lttng_wrap.c lttng.py
 nodist__lttng_la_SOURCES = lttng_wrap.c
 _lttng_la_LDFLAGS = -module
 _lttng_la_LIBADD =     $(top_builddir)/src/lib/lttng-ctl/liblttng-ctl.la               \
-                       $(top_builddir)/src/common/sessiond-comm/libsessiond-comm.la            \
-                       $(top_builddir)/src/common/libcommon.la
+                       $(top_builddir)/src/common/libsessiond-comm.la          \
+                       $(top_builddir)/src/common/libcommon-gpl.la
 
 lttng_wrap.c: lttng.i
        $(SWIG) -python -I. -I$(top_srcdir)/src/common/sessiond-comm lttng.i
This page took 0.023382 seconds and 4 git commands to generate.