Convert LTTngTop to C++ and state system
[lttngtop.git] / src / Makefile.am
index 382cfc2b1d6ae1f13ad03cd5f0873faa0738d99e..e060d65ff639a8575a123c662337d4d7653ed0c5 100644 (file)
@@ -1,4 +1,5 @@
 AM_CFLAGS = $(PACKAGE_CFLAGS)
+AM_CXXFLAGS = $(PACKAGE_CFLAGS)
 
 bin_PROGRAMS = lttngtop
 
@@ -6,14 +7,18 @@ noinst_HEADERS = \
        lttngtoptypes.h \
        common.h \
        cputop.h \
-       cursesdisplay.h \
-       iostreamtop.h
+       iostreamtop.h \
+       cursesdisplay.h
 
 lttngtop_SOURCES = \
-       lttngtop.c \
-       common.c \
-       cursesdisplay.c \
-       cputop.c \
-       iostreamtop.c
+       lttngtop.cpp \
+       common.cpp \
+       cputop.cpp \
+       iostreamtop.cpp \
+       cursesdisplay.cpp
 
-lttngtop_LDADD = -lbabeltrace -lbabeltrace-ctf
+lttngtop_LDADD = \
+       -lbabeltrace \
+       -lbabeltrace-ctf \
+       -lboost_system \
+       -lstate
This page took 0.0230900000000001 seconds and 4 git commands to generate.