Detect and document dependency on -ldl on Linux, -lc on BSD for dlopen
[lttng-ust.git] / tests / hello.cxx / Makefile.am
index 3e84796a731b4ecf965e57bae6d0f0f967190e99..f56f431c70f9800c74ffa37b2d63dfd4a88e9f32 100644 (file)
@@ -4,5 +4,12 @@ noinst_PROGRAMS = hello
 hello_SOURCES = hello.cpp tp.c ust_tests_hello.h
 hello_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la
 
+if LTTNG_UST_BUILD_WITH_LIBDL
+hello_LDADD += -ldl
+endif
+if LTTNG_UST_BUILD_WITH_LIBC_DL
+hello_LDADD += -lc
+endif
+
 noinst_SCRIPTS = run
 EXTRA_DIST = run
This page took 0.022805 seconds and 4 git commands to generate.