Implement liblttng-ust-fork daemon() override test
[lttng-ust.git] / tests / daemon / Makefile.am
diff --git a/tests/daemon/Makefile.am b/tests/daemon/Makefile.am
new file mode 100644 (file)
index 0000000..e641826
--- /dev/null
@@ -0,0 +1,16 @@
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include -Wsystem-headers
+
+noinst_PROGRAMS = daemon
+daemon_SOURCES = daemon.c ust_tests_daemon.h
+daemon_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la \
+               $(top_builddir)/liblttng-ust-fork/liblttng-ust-fork.la
+
+if LTTNG_UST_BUILD_WITH_LIBDL
+daemon_LDADD += -ldl
+endif
+if LTTNG_UST_BUILD_WITH_LIBC_DL
+daemon_LDADD += -lc
+endif
+
+noinst_SCRIPTS = run
+EXTRA_DIST = run
This page took 0.022811 seconds and 4 git commands to generate.