Fix: don't build C++ example if a C++ compiler isn't available
[lttng-ust.git] / tests / Makefile.am
index e79ab7cec1760c256a1b25589ca8037f217608da..1a8b795c691744f7352317db26fd8a54531fee86 100644 (file)
@@ -1,6 +1,10 @@
-SUBDIRS = . hello hello-static-lib fork ust-basic-tracing ust-multi-test demo hello.cxx
+SUBDIRS = . hello hello-static-lib fork ust-basic-tracing ust-multi-test demo
 #SUBDIRS = . hello2 basic basic_long simple_include snprintf test-nevents test-libustinstr-malloc dlopen same_line_marker trace_event register_test tracepoint libustctl_function_tests exit-fast
 
+if CXX_WORKS
+SUBDIRS += hello.cxx
+endif
+
 dist_noinst_SCRIPTS = test_loop runtests trace_matches
 
 noinst_LIBRARIES = libtap.a
This page took 0.023372 seconds and 4 git commands to generate.