Implement liblttng-ust-fd
[lttng-ust.git] / liblttng-ust-fd / Makefile.am
diff --git a/liblttng-ust-fd/Makefile.am b/liblttng-ust-fd/Makefile.am
new file mode 100644 (file)
index 0000000..52f897d
--- /dev/null
@@ -0,0 +1,17 @@
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include
+AM_CFLAGS = -fno-strict-aliasing
+
+lib_LTLIBRARIES = liblttng-ust-fd.la
+liblttng_ust_fd_la_SOURCES = \
+       lttng-ust-fd.c
+liblttng_ust_fd_la_LIBADD = \
+       $(top_builddir)/liblttng-ust-comm/liblttng-ust-comm.la
+
+if LTTNG_UST_BUILD_WITH_LIBDL
+liblttng_ust_fd_la_LIBADD += -ldl
+endif
+if LTTNG_UST_BUILD_WITH_LIBC_DL
+liblttng_ust_fd_la_LIBADD += -lc
+endif
+
+liblttng_ust_fd_la_CFLAGS = -DUST_COMPONENT=liblttng-ust-fd -fno-strict-aliasing
This page took 0.023239 seconds and 4 git commands to generate.