Cleanup: Re-organise source dir
[urcu.git] / tests / utils / Makefile.am
index 24c0bb87942600b6fb26879578e0485af4d92f8d..440ac382a8412e738971869bf5dfdc0ef06f98d9 100644 (file)
@@ -1,3 +1,22 @@
+AM_CFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_srcdir)/src
+
 noinst_LIBRARIES = libtap.a
 libtap_a_SOURCES = tap.c tap.h
-dist_noinst_SCRIPTS = tap.sh
+
+SCRIPT_LIST = tap.sh
+
+dist_noinst_SCRIPTS = $(SCRIPT_LIST)
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.022894 seconds and 4 git commands to generate.