Tests: Replace prove by autotools tap runner
[urcu.git] / tests / unit / Makefile.am
index e6f7b3e01572a668e9d5b53d59c6cbd8ab2b7c64..ade355558b505673b337dec43ebbd32dedb64f8e 100644 (file)
@@ -1,12 +1,14 @@
 AM_CFLAGS += -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_srcdir)/src -I$(top_srcdir)/tests/utils -I$(top_srcdir)/tests/common -g
 
-SCRIPT_LIST = test_loop run.sh unit_tests
+LOG_DRIVER_FLAGS = --merge --comments
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+       $(top_srcdir)/config/tap-driver.sh
 
 noinst_PROGRAMS = test_uatomic \
        test_urcu_multiflavor \
        test_urcu_multiflavor_dynlink
 
-dist_noinst_SCRIPTS = $(SCRIPT_LIST)
+TESTS = $(noinst_PROGRAMS)
 
 noinst_HEADERS = test_urcu_multiflavor.h
 
@@ -55,5 +57,3 @@ clean-local:
                done; \
        fi
 
-check-am:
-       ./run.sh unit_tests
This page took 0.022581 seconds and 4 git commands to generate.