Perform factor reduction as a modular step
[lttv.git] / lttv / lttv / sync / Makefile.am
index dbe9ed59db4b88b7cc14609835771d4cbfe76bcc..e1d67756aa4d7bce8a5fac4cd0ef3b12e2b2f76d 100644 (file)
@@ -1,11 +1,33 @@
 AM_CFLAGS= $(PACKAGE_CFLAGS)
-LDADD = $(M_LIBS)
+LDADD = $(M_LIBS) $(GLPK_LIBS)
 
 check_PROGRAMS = unittest
 
 unittest_SOURCES = \
-       unittest.c\
        data_structures.c\
+       data_structures.h\
+       graph_functions.c\
+       graph_functions.h\
+       sync_chain.c\
+       sync_chain.h\
+       sync_chain_unittest.c\
+       event_processing.h\
+       event_processing_text.c\
+       event_processing_text.h\
+       event_matching.h\
+       event_matching_broadcast.c\
+       event_matching_broadcast.h\
+       event_matching_distributor.c\
+       event_matching_distributor.h\
        event_matching_tcp.c\
+       event_matching_tcp.h\
+       event_analysis.h\
+       event_analysis_chull.c\
+       event_analysis_chull.h\
+       event_analysis_eval.c\
+       event_analysis_eval.h\
        event_analysis_linreg.c\
-       event_analysis_chull.c
+       event_analysis_linreg.h\
+       factor_reduction.h\
+       factor_reduction_accuracy.c\
+       factor_reduction_accuracy.h
This page took 0.022287 seconds and 4 git commands to generate.