Disable sync/ completely, build OK
[lttv.git] / lttv / lttv / Makefile.am
index f81466f17237613944bb4c114d70d87d68d4fe0a..fbf6d6aad21d789f6588be9747787384d4288fe9 100644 (file)
@@ -1,7 +1,7 @@
 SUBDIRS= sync
 
 AM_CFLAGS= $(PACKAGE_CFLAGS)
-LDADD = $(POPT_LIBS) $(M_LIBS) ${top_builddir}/ltt/liblttvtraceread.la
+LDADD = $(POPT_LIBS) $(M_LIBS) $(GLPK_LIBS) ${top_builddir}/ltt/liblttvtraceread.la
 
 bin_PROGRAMS = lttv.real
 
@@ -54,17 +54,22 @@ lttv_real_SOURCES = \
        tracecontext.c\
        traceset.c\
        filter.c\
-       print.c\
-       sync/sync_chain_lttv.c\
-       sync/data_structures.c\
-       sync/event_processing_lttng_common.c\
-       sync/event_processing_lttng_standard.c\
-       sync/event_processing_lttng_null.c\
-       sync/event_matching_tcp.c\
-       sync/event_matching_broadcast.c\
-       sync/event_analysis_linreg.c\
-       sync/event_analysis_chull.c\
-       sync/event_analysis_eval.c
+       print.c
+
+#Disabled by Mathieu Desnoyers (does not build on x86_64)
+#      sync/sync_chain.c\
+#      sync/sync_chain_lttv.c\
+#      sync/graph_functions.c\
+#      sync/data_structures.c\
+#      sync/event_processing_lttng_common.c\
+#      sync/event_processing_lttng_standard.c\
+#      sync/event_processing_lttng_null.c\
+#      sync/event_matching_broadcast.c\
+#      sync/event_matching_distributor.c\
+#      sync/event_matching_tcp.c\
+#      sync/event_analysis_chull.c\
+#      sync/event_analysis_eval.c\
+#      sync/event_analysis_linreg.c
 
 lttvinclude_HEADERS = \
        attribute.h\
This page took 0.022823 seconds and 4 git commands to generate.