Don't compile the sync directory
[lttv.git] / lttv / lttv / Makefile.am
index e63f4d7f66e309af74dce57dae472396f9cb3eaf..f7a93ca32853848ba9bf658ba8dcafc1fb9a427c 100644 (file)
@@ -1,5 +1,8 @@
+#BABEL_CLEANUP
+#SUBDIRS= sync
+
 AM_CFLAGS= $(PACKAGE_CFLAGS)
-LDADD = $(POPT_LIBS) ${top_builddir}/ltt/liblttvtraceread.la
+LDADD = $(POPT_LIBS) $(M_LIBS) $(GLPK_LIBS)
 
 bin_PROGRAMS = lttv.real
 
@@ -39,10 +42,73 @@ libdir = ${lttvplugindir}
 #noinst_HEADERS = \
 #      filter.h
 
-lttv_real_SOURCES = batchtest.c main.c module.c option.c \
-               hook.c attribute.c \
-               iattribute.c state.c stats.c \
-              tracecontext.c traceset.c filter.c print.c
+#disabled for babeltrace port  batchtest.c stats.c     tracecontext.c  filter.c
+
+
+
+lttv_real_SOURCES = \
+       main.c\
+       module.c\
+       option.c\
+       hook.c\
+       attribute.c\
+       iattribute.c\
+       state.c\
+       traceset.c\
+       traceset-process.c\
+       print.c\
+       event.c
+#      sync/sync_chain.c\
+       sync/sync_chain.h\
+       sync/sync_chain_lttv.c\
+       sync/sync_chain_lttv.h\
+       sync/graph_functions.c\
+       sync/graph_functions.h\
+       sync/data_structures.c\
+       sync/data_structures.h\
+       sync/event_processing.h\
+       sync/event_processing_lttng_common.c\
+       sync/event_processing_lttng_common.h\
+       sync/event_processing_lttng_standard.c\
+       sync/event_processing_lttng_standard.h\
+       sync/event_processing_lttng_null.c\
+       sync/event_processing_lttng_null.h\
+       sync/event_matching.h\
+       sync/event_matching_broadcast.c\
+       sync/event_matching_broadcast.h\
+       sync/event_matching_distributor.c\
+       sync/event_matching_distributor.h\
+       sync/event_matching_tcp.c\
+       sync/event_matching_tcp.h\
+       sync/event_analysis.h\
+       sync/event_analysis_chull.c\
+       sync/event_analysis_chull.h\
+       sync/event_analysis_eval.c\
+       sync/event_analysis_eval.h\
+       sync/event_analysis_linreg.c\
+       sync/event_analysis_linreg.h\
+       sync/factor_reduction.h\
+       sync/factor_reduction_accuracy.c\
+       sync/factor_reduction_accuracy.h\
+       sync/lookup3.h
+
+lttvinclude_HEADERS = \
+       attribute.h\
+       hook.h\
+       iattribute.h\
+       lttv.h\
+       module.h\
+       option.h\
+       state.h\
+       stats.h\
+       traceset-process.h\
+       traceset.h\
+       filter.h\
+       print.h\
+       compiler.h\
+       time.h\
+       event.h\
+       trace.h
 
 #man_MANS = lttv.1
 #EXTRA_DIST = lttv.1
This page took 0.023039 seconds and 4 git commands to generate.